덱 - 10866


Published on October 22, 2021 by Hyle

큐/덱

5 min READ

문제

정수를 저장하는 덱(Deque)를 구현한 다음, 입력으로 주어지는 명령을 처리하는 프로그램을 작성하시오.

명령은 총 여덟 가지이다.

  • push_front X: 정수 X를 덱의 앞에 넣는다.
  • push_back X: 정수 X를 덱의 뒤에 넣는다.
  • pop_front: 덱의 가장 앞에 있는 수를 빼고, 그 수를 출력한다. 만약, 덱에 들어있는 정수가 없는 경우에는 -1을 출력한다.
  • pop_back: 덱의 가장 뒤에 있는 수를 빼고, 그 수를 출력한다. 만약, 덱에 들어있는 정수가 없는 경우에는 -1을 출력한다.
  • size: 덱에 들어있는 정수의 개수를 출력한다.
  • empty: 덱이 비어있으면 1을, 아니면 0을 출력한다.
  • front: 덱의 가장 앞에 있는 정수를 출력한다. 만약 덱에 들어있는 정수가 없는 경우에는 -1을 출력한다.
  • back: 덱의 가장 뒤에 있는 정수를 출력한다. 만약 덱에 들어있는 정수가 없는 경우에는 -1을 출력한다.

입력

첫째 줄에 주어지는 명령의 수 N (1 ≤ N ≤ 10,000)이 주어진다. 둘째 줄부터 N개의 줄에는 명령이 하나씩 주어진다. 주어지는 정수는 1보다 크거나 같고, 100,000보다 작거나 같다. 문제에 나와있지 않은 명령이 주어지는 경우는 없다.

출력

출력해야하는 명령이 주어질 때마다, 한 줄에 하나씩 출력한다.

예제 입력 1 복사

15
push_back 1
push_front 2
front
back
size
empty
pop_front
pop_back
pop_front
size
empty
pop_back
push_front 3
empty
front

예제 출력 1 복사

2
1
2
0
2
1
-1
0
1
-1
0
3

예제 입력 2 복사

22
front
back
pop_front
pop_back
push_front 1
front
pop_back
push_back 2
back
pop_front
push_front 10
push_front 333
front
back
pop_back
pop_back
push_back 20
push_back 1234
front
back
pop_back
pop_back

예제 출력 2 복사

-1
-1
-1
-1
1
1
2
2
333
10
10
333
20
1234
1234
20

On my way

import sys
from collections import deque
n = int(sys.stdin.readline().strip())
queue = deque([])
for i in range(n):
    line = sys.stdin.readline().strip().split()
    if line[0] == "push_front": queue.appendleft(line[1])
    elif line[0] == "push_back": queue.append(line[1])
    elif line[0] == "pop_front": print(queue.popleft()) if queue else print(-1)
    elif line[0] == "pop_back": print(queue.pop()) if queue else print(-1)
    elif line[0] == "size": print(len(queue))
    elif line[0] == "empty": print(0) if queue else print(1)
    elif line[0] == "front": print(queue[0]) if queue else print(-1)
    elif line[0] == "back": print(queue[-1]) if queue else print(-1)

💡elif (1번째 조건문): (조건을 충족할 때 명령문) if (2번째 조건문) else (조건을 충족 못 할 때 명령문)

On other way

def push_front(x, deq):
    tmp = [x]
    tmp.extend(deq)
    deq = tmp
    return deq

def push_back(x, deq):
    deq.append(x)
    return deq

def pop_front(deq):
    if deq : 
        print(deq.pop(0))
    else : #빈 리스트 == False
        print(-1)
    
def pop_back(deq):
    if deq :
        print(deq.pop())
    else :
        print(-1)

def size(deq):
    print(len(deq))

def empty(deq) :
    if not deq : 
        print(1)
    else : 
        print(0)
    
def front(deq) :
    if deq :
        print(deq[0])
    else :
        print(-1)
    
def back(deq) :
    if deq :
        print(deq[-1])
    else :
        print(-1)
        
        
statements_dict = {
    'push_front' : push_front,
    'push_back' : push_back,
    'pop_front' : pop_front,
    'pop_back' : pop_back,
    'size' : size,
    'empty' : empty, 
    'front' : front,
    'back' : back
}

N = int(input())

deq = []

for _ in range(N) :
    statement = input().split(" ")
    
    if len(statement) == 1 : 
        command = statement[0]
        statements_dict[command](deq)
    else :
        command, x = statement
        deq = statements_dict[command](x, deq)

💡 switch - case 문을 dictionary를 이용해서 구현했고

def push_front(x, deq): tmp = [x] tmp.extend(deq) deq = tmp return deq

extend에 대해서도 알 수 있었다.