Queue2


Published on October 18, 2021 by Hyle

큐/덱

3 min READ

큐 2

문제

정수를 저장하는 큐를 구현한 다음, 입력으로 주어지는 명령을 처리하는 프로그램을 작성하시오.

명령은 총 여섯 가지이다.

  • push X: 정수 X를 큐에 넣는 연산이다.
  • pop: 큐에서 가장 앞에 있는 정수를 빼고, 그 수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.
  • size: 큐에 들어있는 정수의 개수를 출력한다.
  • empty: 큐가 비어있으면 1, 아니면 0을 출력한다.
  • front: 큐의 가장 앞에 있는 정수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.
  • back: 큐의 가장 뒤에 있는 정수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.

입력

첫째 줄에 주어지는 명령의 수 N (1 ≤ N ≤ 2,000,000)이 주어진다. 둘째 줄부터 N개의 줄에는 명령이 하나씩 주어진다. 주어지는 정수는 1보다 크거나 같고, 100,000보다 작거나 같다. 문제에 나와있지 않은 명령이 주어지는 경우는 없다.

출력

출력해야하는 명령이 주어질 때마다, 한 줄에 하나씩 출력한다.

예제 입력 1 복사

15
push 1
push 2
front
back
size
empty
pop
pop
pop
size
empty
pop
push 3
empty
front

예제 출력 1 복사

1
2
2
0
1
2
-1
0
1
-1
0
3

On my way

import sys
from collections import deque
 
N = int(input())
queue = deque()
 
for _ in range(N):
    input = sys.stdin.readline().rstrip().split
    order = input()
    if order[0]=='push':
        queue.append(order[1])
    elif order[0]=='pop':
        if queue:
            print(queue.popleft())
        else:
            print("-1")
    elif order[0]=='size':
        print(len(queue))
    elif order[0]=='empty':
        if not queue:
            print(1)
        else:
            print(0)
    elif order[0]=='front':
        if queue:
            print(queue[0])
        else:
            print("-1")
    elif order[0]=='back':
        if queue:
            print(queue[-1])
        else:
            print("-1")

💡

On other way

import sys
from collections import deque
 
 
input = sys.stdin.readline
if __name__ == '__main__':
    N = int(*map(int, input().split()))
 
    queue = deque()
    for _ in range(N):
        cmd = list(map(str, input().split()))
        
        #cmd 값에 따른 동작
        if cmd[0] == 'push':
            queue.append(cmd[1])
 
        elif cmd[0] == 'pop':
            try:
                pop_data = queue.popleft()
                print(pop_data)
            except:
                print(-1)
 
        elif cmd[0] == 'size':
            print(len(queue))
 
        elif cmd[0] == 'empty':
            print(1 if len(queue) == 0 else 0)
 
        elif cmd[0] == 'front':
            try:
                print(queue[0])
            except:
                print(-1)
 
        elif cmd[0] == 'back':
            try:
                print(queue[-1])
            except:
                print(-1)

💡

try:

except: